Search found 18 matches

by curiousaaron
Mon Jul 18, 2011 8:51 am
Forum: WCK
Topic: World not paused, but nothing's moving
Replies: 1
Views: 781

Re: World not paused, but nothing's moving

Yeah, I was importing physics settings from XML and the string 'false' was being passed as the value for isGround... which evaluated as a Boolean 'true'. So everything was being treated as ground.

D'oh!
by curiousaaron
Fri Jul 15, 2011 3:06 pm
Forum: WCK
Topic: World not paused, but nothing's moving
Replies: 1
Views: 781

World not paused, but nothing's moving

Anyone encountered this?

The world and all the bodies are created dynamically. I've confirmed via trace that my world is not paused and my bodies are Dynamic and awake. I have a buoyancy object with liquid waves and they're moving.

It's probably something obvious that I'm overlooking...
by curiousaaron
Thu Jul 07, 2011 7:21 am
Forum: WCK
Topic: Error #1009 After Removing Body
Replies: 1
Views: 1292

Error #1009 After Removing Body

I get this error when I remove a body that my 'hero' is in contact with. I am removing via removeChild(). TypeError: Error #1009: Cannot access a property or method of a null object reference. at misc::Util$/localizeMatrix()[/source/misc/Util.as:210] at wck::BodyShape/syncTransform()[/source/wck/Bod...
by curiousaaron
Wed Jul 06, 2011 10:23 am
Forum: WCK
Topic: End contact doesn't fire?
Replies: 7
Views: 2316

Re: End contact doesn't fire?

I am getting a #1009 after removing a body as well. I am using removeChild() (as I've seen mayobutter recommend so many times). I've also tried removing the child outside the time step to no avail. Any ideas? TypeError: Error #1009: Cannot access a property or method of a null object reference. at m...
by curiousaaron
Thu Jun 23, 2011 9:54 am
Forum: WCK
Topic: Platform Stops Working After Tween
Replies: 5
Views: 1304

Re: Platform Stops Working After Tween

After several tries, adding a new instance of the Platform MC just magically fixed it. I love magic.
by curiousaaron
Wed Jun 22, 2011 12:53 pm
Forum: WCK
Topic: Platform Stops Working After Tween
Replies: 5
Views: 1304

Re: Platform Stops Working After Tween

Everybody's set to Animated. Good to know about 'tweened'. I was just trying everything :)
by curiousaaron
Wed Jun 22, 2011 11:37 am
Forum: WCK
Topic: Platform Stops Working After Tween
Replies: 5
Views: 1304

Re: Platform Stops Working After Tween

Maybe I didn't explain, the BodyShape is animated, not the platforms. I set them to 'animated' and tweened trying to get it to work. But one of the platforms stops working after the parent BodyShape animates. There are no additional keyframes, it's all ActionScript tweening. And I have septuple chec...
by curiousaaron
Wed Jun 22, 2011 8:50 am
Forum: WCK
Topic: Platform Stops Working After Tween
Replies: 5
Views: 1304

Platform Stops Working After Tween

I'm having a strange problem where a certain Platform stops working after I tween it's rotation. It's set to Animated and tweened=true and nested within a BodyShape. It works fine, I rotate it's parent BodyShape, then rotate back into place, and it no longer works. What's odd is that it has a siblin...
by curiousaaron
Thu May 12, 2011 1:49 pm
Forum: WCK
Topic: Loading External BodyShape
Replies: 3
Views: 907

Re: Loading External BodyShape

I solved this by nesting my extension of BodyShape within the FLA (rather than having the document class itself extend BodyShape). I was then able to instantiate the class once the SWF loaded. But I am curious if it's possible to do it the other way...
by curiousaaron
Thu May 12, 2011 1:21 pm
Forum: WCK
Topic: Loading External BodyShape
Replies: 3
Views: 907

Loading External BodyShape

Maybe someone can answer this faster than I can figure it out... I've got an FLA with a document class that extends wck.BodyShape. I want to load the compiled SWF into a World instance in an SWF that extends wck.WCK. However, when I add my BodyShape, it ceases to behave as a BodyShape, and instead, ...

Go to advanced search